Wednesday, May 31, 2006

 

Routing Problem with Discontiguous Subnet. (Problem #68)



Consider the network in the diagram above. (Click on image to see full-size figure.) The configuration on the routers is as follows

R1

interface Loopback0
ip address 172.16.5.1 255.255.255.0
!
interface Ethernet0
ip address 12.1.1.1 255.255.255.0
!
router eigrp 100
network 12.0.0.0
network 172.16.0.0
auto-summary


R2

interface Ethernet0
ip address 12.1.1.2 255.255.255.0
!
interface Ethernet1
ip address 23.1.1.1 255.255.255.0
!
router eigrp 100
network 12.0.0.0
network 23.0.0.0
auto-summary


R3

interface Loopback0
ip address 172.16.6.1 255.255.255.0
!
interface Ethernet0
ip address 23.1.1.2 255.255.255.0
!
router eigrp 100
network 23.0.0.0
network 172.16.0.0
auto-summary



With this configuration, trying to ping the loopback interfaces on R1 or R3 from R2 result in every other ping failing as shown below

R2#ping 172.16.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.5.1, timeout is 2 seconds:
!U!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 20/24/32 ms


This is expected because of the auto-summarization that EIGRP has on by default.

Your task in this problem is to fix these failing pings under the constraint that no modification of the configuration under the EIGRP router process is allowed on any router. After your solution is implemented, pings to both 172.16.5.1 and 172.16.6.1 should result in 100% success rates.

This page is powered by Blogger. Isn't yours?