Wednesday, June 14, 2006

 

OSPF Database Summary. (Problem #72)


Consider the network shown above with the configuration on the three
routers as follows -

Router R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial2
ip address 12.1.1.1 255.255.255.0
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 1
network 12.1.1.0 0.0.0.255 area 1


Router R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2
ip address 12.1.1.2 255.255.255.0
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.1.1.0 0.0.0.255 area 1
network 23.1.1.0 0.0.0.255 area 0


Router R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial2
ip address 23.1.1.2 255.255.255.0
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
redistribute connected subnets
network 23.1.1.0 0.0.0.255 area 0


Now consider the following output from the show ip ospf database database-summary command taken on router R1. The first command was issued with the configuration shown above and the subsequent outputs were taken after some configuration changes on the routers in the network which are not specified in this problem.

Output #1

R1#sh ip ospf database database-summary

OSPF Router with ID (1.1.1.1) (Process ID 100)

Area 1 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 2 0 0
Summary ASBR 1 0 0
Type-7 Ext 0 0 0
Prefixes redistributed in Type-7 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Subtotal 5 0 0

Process 100 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 2 0 0
Summary ASBR 1 0 0
Type-7 Ext 0 0 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Type-5 Ext 1 0 0
Prefixes redistributed in Type-5 0
Opaque AS 0 0 0
Total 6 0 0
R1#


Output #2

R1#sh ip ospf database database-summary

OSPF Router with ID (1.1.1.1) (Process ID 100)

Area 1 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 1 0 0
Summary ASBR 0 0 0
Type-7 Ext 0 0 0
Prefixes redistributed in Type-7 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Subtotal 3 0 0

Process 100 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 1 0 0
Summary ASBR 0 0 0
Type-7 Ext 0 0 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Type-5 Ext 0 0 0
Prefixes redistributed in Type-5 0
Opaque AS 0 0 0
Total 3 0 0
R1#


Output #3

R1#sh ip ospf database database-summary

OSPF Router with ID (1.1.1.1) (Process ID 100)

Area 1 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 3 0 0
Summary ASBR 0 0 0
Type-7 Ext 0 0 0
Prefixes redistributed in Type-7 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Subtotal 5 0 0

Process 100 database summary
LSA Type Count Delete Maxage
Router 2 0 0
Network 0 0 0
Summary Net 3 0 0
Summary ASBR 0 0 0
Type-7 Ext 0 0 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Type-5 Ext 0 0 0
Prefixes redistributed in Type-5 0
Opaque AS 0 0 0
Total 5 0 0
R1#


Your task in this problem is to look at the output and reverse engineer what config changes must have been done to cause the changes in the output shown above. Note that you have to specify what happened between output #1 and output #2 and then what happened between output #2 and output #3.

This page is powered by Blogger. Isn't yours?