Sunday, February 19, 2006
RIP version mismatch. (Question #17)
Consider a simple three router network such as the following
Router1 ---- Router2 ---- Router3
Assume that the routers are all connected to each other over ethernet interfaces and that the interfaces are up and the neighbors can ping each other. The subnet on the left is 10.10.10.0/24 and that on the right is 20.20.20.0/24
Here is the relevant snippet relating to the configuration of the RIP routing protocol on the three routers
Router1
Router2
Router3
Note that the router in the middle is running RIPv2 while the other two routers are running RIPv1. Will the version mismatch cause a problem with routing in this network? Can Router3 ping interfaces on Router1 if there is no other routing related configuration on the routers other than the RIP configuration shown above?
Router1 ---- Router2 ---- Router3
Assume that the routers are all connected to each other over ethernet interfaces and that the interfaces are up and the neighbors can ping each other. The subnet on the left is 10.10.10.0/24 and that on the right is 20.20.20.0/24
Here is the relevant snippet relating to the configuration of the RIP routing protocol on the three routers
Router1
router rip
network 10.0.0.0
Router2
router rip
version 2
network 10.0.0.0
network 20.0.0.0
Router3
router rip
network 20.0.0.0
Note that the router in the middle is running RIPv2 while the other two routers are running RIPv1. Will the version mismatch cause a problem with routing in this network? Can Router3 ping interfaces on Router1 if there is no other routing related configuration on the routers other than the RIP configuration shown above?
Duplicate IP address detection. (Question #16)
If you mistakenly configure the same IP address on ethernet interfaces of two different routers in the same subnet you will see a message like the following
How do you think the duplicate address detection is done? Are there any debugs you can turn on on the router to verify if your answer is correct?
*Feb 20 05:42:46.579: %IP-4-DUPADDR: Duplicate address 20.20.20.2 on Ethernet1, sourced by 00c0.3412.0922
How do you think the duplicate address detection is done? Are there any debugs you can turn on on the router to verify if your answer is correct?
Missing default route. (Question #15)
The configuration on a router has the following line
to specify a default route. However, "show ip route" issued on the router does not show any default route. What could be the reason for the default route not showing up in the routing table?
ip route 0.0.0.0 0.0.0.0 172.16.1.2
to specify a default route. However, "show ip route" issued on the router does not show any default route. What could be the reason for the default route not showing up in the routing table?