Wednesday, February 15, 2006
GRE and policy routing. (Question #11)
Consider the following topology
Client -- R1 ---- R2 -- Gateway -- Web server (22.1.1.1)
There is a GRE tunnel between routers R1 and R2.
R1 has the following config
and router R2 has the following config
In addition, on router R2 the following additional config is seen -
Now here are some questions regarding this set-up -
1. What purpose is the keepalive on the tunnel serving?
2. What is the route-map doing?
3. Think up a scenario for a problem that is being solved by policy routing in the example above.
Client -- R1 ---- R2 -- Gateway -- Web server (22.1.1.1)
There is a GRE tunnel between routers R1 and R2.
R1 has the following config
interface Tunnel1
ip address 20.20.20.1 255.255.255.0
keepalive 10 5
tunnel source 10.10.10.1
tunnel destination 10.10.10.2
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no keepalive
and router R2 has the following config
interface Tunnel1
ip address 20.20.20.2 255.255.255.0
keepalive 10 5
tunnel source 10.10.10.2
tunnel destination 10.10.10.1
!
interface Ethernet0
ip address 10.10.10.2 255.255.255.0
no keepalive
In addition, on router R2 the following additional config is seen -
interface ethernet0
ip policy route-map mystery
route-map mystery permit 10
match ip address 101
set ip df 0
access-list 101 permit tcp 22.1.1.0 0.0.0.255 any
Now here are some questions regarding this set-up -
1. What purpose is the keepalive on the tunnel serving?
2. What is the route-map doing?
3. Think up a scenario for a problem that is being solved by policy routing in the example above.