Friday, June 30, 2006

 

Routing with ODR. (Problem #76)

On-demand Routing (ODR) is an interesting option for use in hub and spoke configurations. This is a subject that is included in the CCIE and CCNP exams but it is my impression that this gets short shrift in the usual preparation material for these exams. This blog post poses a problem that occurs while running ODR in a small network.


Consider the above network with one hub and two spoke routers. The hub router is running ODR. The configuration of the three routers is given below

HUB

hostname HUB
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2
ip address 23.1.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 23.1.1.2 223
frame-relay interface-dlci 223
no frame-relay inverse-arp
!
router odr
!
ip classless


SPOKE1

hostname SPOKE1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 12.1.1.1 255.255.255.0


SPOKE2

hostname SPOKE2
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial2
ip address 23.1.1.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 23.1.1.1 322
frame-relay interface-dlci 322
no frame-relay inverse-arp


Now when the routing table on the HUB router is checked, we see the following

HUB#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
o 1.1.1.0 [160/1] via 12.1.1.1, 00:00:08, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
C 23.1.1.0 is directly connected, Serial2/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Ethernet0/0


Note that there is an ODR route to 1.1.1.1/32 as we expect but none to 3.3.3.3/32 as would have been expected.

What is the reason for the missing ODR learnt route to 3.3.3.3/32? How can this be fixed such that an ODR route to 3.3.3.3/32 gets installed in the routing table of the HUB router?

Comments:
Good Morning,

Since Spokes are sending ODR updates using CDP packets, check to see if HUB router is able to see SPOKE2 as its CDP neighboro.

------
Networker
 
That's the right direction. Let's say that the check you suggest is done and it is seen that the HUB router is unable to see SPOKE2. Now, given this information, how do you fix this problem?
 
I guess that if there is a problem with the cdp you would need to enable the broadcasting of it over frame-relay. You could add the broadcast attribute on both hub and spoke.

frame-relay map ip 23.1.1.1 322 broadcast
frame-relay interface-dlci 322 (remove see below?)
no frame-relay inverse-arp (doesn't this negate the frame-relay interface-dlci?)
 
Yes, that's right Rich. Adding "broadcast" to the frame relay map statement will fix the problem.
 
Agree, plus you need to enable cdp on serial interface (default CDP disabled on serial int).
 
This comment has been removed by a blog administrator.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?