Friday, May 19, 2006

 

RIP over Frame Relay. (Question #66)



Consider the network in shown the diagram above. (Click on the figure to see a bigger clearer version.) Here is the configuration for the two routers in the network diagram

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial2
ip address 10.10.10.1 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay map ip 10.10.10.2 102
frame-relay interface-dlci 102
no frame-relay inverse-arp
!
router rip
network 1.0.0.0
network 10.0.0.0


R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2
ip address 10.10.10.2 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay map ip 10.10.10.1 201
frame-relay interface-dlci 201
no frame-relay inverse-arp
!
router rip
network 2.0.0.0
network 10.0.0.0


With this configuration, it is observed that routes to the loopback interfaces on the peer router are not seen. In fact, no RIP routes are seen because RIP uses broadcasts for its routing updates and the frame relay maps in the configs for both routers is missing the "broadcast" keyword.

Your task in this problem is to get RIP working without modifying the existing frame relay map statements in any way. After the solution is implemented, RIP routes to the loopback interfaces in the peer router should be installed in the routing table.

Comments:
You need to set it up for RIP version 2 and make use of neighbor commands which allow unicast updates.

R1
router rip
network 1.0.0.0
network 10.0.0.0
neighbor 10.10.10.2
version 2

R2

router rip
network 2.0.0.0
network 10.0.0.0
neighbor 10.10.10.1
version 2
 
That's the right answer Rich.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?