Thursday, May 18, 2006

 

RIP and a Strangely Configured Subnet. (Problem #65)

Here is a problem that is not quite a practical situation perhaps but one that allows itself to be solved with the facilities provided by Cisco IOS.


Consider the network represented in the figure above. (Click on the image to see a larger and readable rendering.) Note that the addressing on the ethernet subnet is strange in that the ethernet interface on router R3 is configured to be in a different subnet compared with the ethernet interfaces on routers R1 and R2. The three routers are also configured with loopback interfaces with addresses as indicated in the figure.

Your task in this problem is to turn on RIP routing between the three routers and allow each router to ping the loopback interfaces on the other two routers without modifying the interface addresses on any router.

Comments:
hello!
I study ccna and ccnp for jobs.
I'm a beginner engineer.
thanks for your knowledge!
 
So what's the answer to this?
 
You just change Router 3 to send updates and accept updates out of all interfaces.

Router 1

router rip
version 2
network 1.0.0.0
network 192.168.1.0
no auto-summary
!

Router 2

router rip
version 2
network 2.0.0.0
network 192.168.1.0
no auto-summary
!

Router 3

router rip
version 2
network 3.0.0.0
network 0.0.0.0
no auto-summary
!
 
So why would not a 172 network statement allow this to work? Maybe i'm overthinking this one
 
I took another look at this and I think that you can also use 172 but you need both network statements on all 3 routers. In addition you need "no validate-update-source"

I believe the final version should be:

Router 1

router rip
version 2
no validate-update-source
network 1.0.0.0
network 172.16.0.0
network 192.168.1.0
no auto-summary
!

Router 2

router rip
version 2
no validate-update-source
network 2.0.0.0
network 172.16.0.0
network 192.168.1.0
no auto-summary
!

Router 3

router rip
version 2
no validate-update-source
network 3.0.0.0
network 172.16.0.0
network 192.168.1.0
no auto-summary
!
 
Rich, your final answer will do the trick. The question was somewhat contrived but I was trying to find a reason to use "no validate-update-source".
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?