Monday, May 15, 2006
Manipulating the ARP Cache. (Question #64)
Consider two routers connected back-to-back via their ethernet interfaces. The configs on the two routers is as follows
Router1
Router2
Now, assume that a ping is initiated from Router1 to 20.0.0.1 and 30.0.0.1. The pings succeed and "show arp" on Router1 shows
Your task in this problem is to come up with two different ways in which the config of Router1 can be modified such that if you ping 20.0.0.1 and 30.0.0.1 from Router1, "show arp" on Router1 will show up as
Router1
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
!
ip route 20.0.0.0 255.255.255.0 10.0.0.2
ip route 30.0.0.0 255.255.255.0 10.0.0.2
Router2
interface Loopback0
ip address 20.0.0.1 255.255.255.255
no clns route-cache
!
interface Loopback1
ip address 30.0.0.1 255.255.255.255
no clns route-cache
!
interface Ethernet0
ip address 10.0.0.2 255.255.255.0
no clns route-cache
Now, assume that a ping is initiated from Router1 to 20.0.0.1 and 30.0.0.1. The pings succeed and "show arp" on Router1 shows
Router1#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.2 18 0000.cc00.8400 ARPA Ethernet0
Internet 10.0.0.1 - 0000.cc00.8300 ARPA Ethernet0
Your task in this problem is to come up with two different ways in which the config of Router1 can be modified such that if you ping 20.0.0.1 and 30.0.0.1 from Router1, "show arp" on Router1 will show up as
Router1#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.2 0 0000.cc00.8400 ARPA Ethernet0
Internet 10.0.0.1 - 0000.cc00.8300 ARPA Ethernet0
Internet 20.0.0.1 0 0000.cc00.8400 ARPA Ethernet0
Internet 30.0.0.1 1 0000.cc00.8400 ARPA Ethernet0