Wednesday, April 12, 2006

 

Equal-cost Paths with RIP. (Question #52)

Consider two routers connected back-to-back with each other via a pair of serial interfaces. The routers are running RIP to advertise their loopbacks to each other. Here is the config from the two routers

Router1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial2
ip address 20.20.20.1 255.255.255.0
no keepalive
!
interface Serial3
ip address 30.30.30.1 255.255.255.0
no keepalive


Router2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2
ip address 20.20.20.2 255.255.255.0
no keepalive
!
interface Serial3
ip address 30.30.30.2 255.255.255.0
no keepalive


Now consider the following output from "show ip route 2.2.2.2" on router R1

R1#show ip route 2.2.2.2
Routing entry for 2.0.0.0/8
Known via "rip", distance 120, metric 1
Redistributing via rip
Last update from 20.20.20.2 on Serial2, 00:00:10 ago
Routing Descriptor Blocks:
* 20.20.20.2, from 20.20.20.2, 00:00:10 ago, via Serial2
Route metric is 1, traffic share count is 1


Note that R1 sees only one route to 2.2.2.2 via 20.20.20.2 even though clearly it has another path with the same cost via 30.30.30.2.

Your task is to determine using the information provided what must have been configured under the rip router configuration to cause only one path to 2.2.2.2 to be installed in the routing table.

Comments:
Router2

router rip

passive-interface Serial3
 
Your answer is correct for the problem as it is currently stated. However, I had something else in mind and in order to extract that answer let me also add this further constraint to the problem.

Assume that you do a "shutdown" on serial2 of either router. If I were to tell you that now a route to the peer's loopback interface appears in the routing table via interface serial3, then what do you think must have been configured under "router rip" to cause the behavior originally stated in the problem?
 
I'm thinking that an offset-list has been configured to increase the metric of inbound RIP updates coming from serial 3.

This would make sure load balancing did not happen between interfaces, however they'd still dynamically participate in the RIP updates and convergence.

Perhaps something like this under router configuration mode:

offset-list 10 in 0 serial3
 
oops, my previous comment had an offset of 0, which would do nothing. It would be an offset of at least 1.
 
What I had in mind was a much simpler way. By default RIP will use up to 4 equal-cost paths but that can be changed with the command

maximum-paths 1

under the router rip configuration to cause the behavior described in the problem.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?