Friday, April 28, 2006

 

DHCP Trouble. (Question #62)

Consider three routers named HOST, RELAY and DHCP-SERVER connected as in the following topology

HOST e0 ---- e0 RELAY e1 ---- e0 DHCP-SERVER

It is seen that the HOST which is configured to obtain the IP address for its ethernet0 interface using DHCP is failing to successfully get its address. Given the following configuration for the three routers in question, can you figure out what the problem is?

HOST

interface Ethernet0
ip address dhcp


RELAY

interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip helper-address 20.20.20.2
!
interface Ethernet1
ip address 20.20.20.1 255.255.255.0
!
ip forward-protocol udp bootpc
ip forward-protocol udp bootps


DHCP-SERVER

ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool NET10
network 10.10.10.0 255.255.255.0
!
interface Ethernet0
ip address 20.20.20.2 255.255.255.0


Comments:
Maybe you need a route from the DHCP server to subnet 10.10.10.0/24?
 
Yes, that's the right answer Rich.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?