Saturday, March 11, 2006

 

IS-IS neighbor problems on NBMA network. (Question #37)

Consider two routers connected to each other via frame relay serial interfaces. The routers are able to ping each other but when IS-IS is configured on the routers, they fail to form neighbor adjacencies. Here is the config from the two routers

Router1

interface Serial2/0
ip address 10.10.10.1 255.255.255.0
ip router isis
encapsulation frame-relay
frame-relay map ip 10.10.10.1 102
frame-relay interface-dlci 102
!
router isis
net 49.0100.1111.1111.1111.00
is-type level-1


Router2

interface Serial2/0
ip address 10.10.10.2 255.255.255.0
ip router isis
encapsulation frame-relay
frame-relay map ip 10.10.10.2 201
frame-relay interface-dlci 201
!
router isis
net 49.0100.2222.2222.2222.00
is-type level-1


What needs to be done to get the two routers to see each other as IS-IS neighbors?

Comments:
The neighbours have to have their CLNS addresses mapped (IS-IS is all CLNS, not IP)

frame-relay map clns 102/201 broadcast

depending on which router you're on.

Also see http://ccnprecertification.com/2004/03/26/is-is-multiareas-and-frame-relay/
 
That's correct Sean.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?