Friday, March 17, 2006

 

EIGRP over point-to-multipoint Frame Relay network. (Question #43)

Consider three routers connected in a hub and spoke arrangement over frame relay. EIGRP has been configured on all the routers but show ip route on the spoke routers indicates that while they have routes to networks on the hub router, they don't have any routes to networks connected to the peer spoke router.

Here are the configs from the routers -

HUB

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial2/0
ip address 10.10.10.1 255.255.255.0
encapsulation frame-relay
no ip route-cache
no keepalive
frame-relay interface-dlci 102
frame-relay interface-dlci 103
!
router eigrp 100
network 1.1.1.1 0.0.0.0
network 10.10.10.0 0.0.0.255
no auto-summary


SPOKE-1

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2/0
ip address 10.10.10.2 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay interface-dlci 201
!
router eigrp 100
network 2.2.2.2 0.0.0.0
network 10.10.10.0 0.0.0.255
no auto-summary


SPOKE-2

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial2/0
ip address 10.10.10.3 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay interface-dlci 301
!
router eigrp 100
network 3.3.3.3 0.0.0.0
network 10.10.10.0 0.0.0.255
no auto-summary


List all the configuration changes necessary to cause the spoke routers to be able see routes to all networks behind the peer spoke router and then also be able to ping all those networks.

Comments:
This comment has been removed by the author.
 
it has Eigrp split horizon issue...Bcoz we use framrelay in sub interfaces or pure mulipoint multi access network...anyhow...we uses the single physical inter face(serialPort)...so eigrp gets up date from one spokes router...it dosnt send to othre spokes routers using this same interface...unless we mannuly disable the split hoizon in Interface config uration mode..


command


int serial 0


no ip splithorizon eigrp as Number
 
@ nasee.. nice.. it was very usefull.. thank you:)
 
Pretty section of content. I just stumbled upon your
site and in accession capital to assert that I acquire actually enjoyed account your blog posts.
Anyway I'll be subscribing to your feeds and even I achievement you access consistently quickly.

my web page :: ideal waist To Hip ratio
 
Pretty section of content. I just stumbled upon your site and in accession capital to assert that I acquire actually enjoyed account your blog posts.
Anyway I'll be subscribing to your feeds and even I achievement you access consistently quickly.

Also visit my web blog; ideal waist To Hip ratio
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?