Wednesday, March 29, 2006

 

Dialer Profiles. (Question #50)

The following routers are connected back-to-back with ISDN PRI network-side simulation configured on one end. With the configuration shown below, pings to the far end IP addresses fail. However if the dialer2 interface is unconfigured from both routers, then the call comes up and the other end can be pinged. The same is true if the dialer1 interface is removed from both routers. If both dialer interfaces are configured as below on both routers, then no pings succeed and calls do not come up.

What is the problem here and how can it be fixed?

Router1

isdn switch-type primary-5ess
!
controller T1 4
framing esf
linecode ami
pri-group timeslots 1-24
!
interface Serial4/0:23
no ip address
dialer pool-member 1
isdn switch-type primary-5ess
isdn protocol-emulate network
no cdp enable
!
interface Dialer1
ip address 10.10.10.1 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 2222222
dialer-group 1
!
interface Dialer2
ip address 20.20.20.1 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 222
dialer-group 1
!
dialer-list 1 protocol ip permit


Router2

isdn switch-type primary-5ess
!
controller T1 4
framing esf
linecode ami
pri-group timeslots 1-24
!
interface Serial4/0:23
no ip address
dialer pool-member 1
isdn switch-type primary-5ess
no cdp enable
!
interface Dialer1
ip address 10.10.10.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 1111111
dialer-group 1
!
interface Dialer2
ip address 20.20.20.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 111
dialer-group 1
!
dialer-list 1 protocol ip permit


Comments:
The problem is that the dialer-list 1 points to both logical dialers (with dialer-group 1) which is confusing and not allowed. To solve this problem I can only think of removing either dialer1 or dialer2 from both routers.
 
No, removing one dialer interface is not an option. Try and frame a solution that works with both dialer interfaces configured on both routers.
 
The problem is the router doesn't know which dialer profile to match for dialin. You can just setup using caller id or authentication to match it.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?