Wednesday, February 08, 2006

 

Trouble with OSPF neighbors. (Question #7)

Consider two routers directly connected to each other using their serial interfaces. The routing protocol being run on the two routers is OSPF. Given the relevant config below for the two routers, can you determine why the two routers are not successfully becoming OSPF neighbors? Note that the interfaces are up and can ping each other.

Router #1

interface Serial0
ip address 20.20.20.1 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay interface-dlci 901
!
router ospf 100
log-adjacency-changes
network 20.20.20.1 0.0.0.0 area 0


Router #2

interface Serial0
ip address 20.20.20.2 255.255.255.0
encapsulation frame-relay
no keepalive
frame-relay interface-dlci 801
!
router ospf 100
log-adjacency-changes
network 20.20.20.2 0.0.0.0 area 0

Comments:
The reason OSPF will not allow them to become neighbors is because frame-relay by nature is a Non-Broadcast network (NBMA, Non-Broadcast, Multi-Access), denying the necessary multicast communications that OSPF relies upon (224.0.0.5, 224.0.0.6).

To permit neighboring over a frame-relay connection, you must specify the OSPF network type at the interface level. RFC compliant methods are non-broadcast (NBMA) and point-to-multipoint.

Cisco implemented proprietary methods called point-to-point, point-to-multipoint nonbroadcast, and broadcast. Each one acts slightly different and is based on choice of how you want the link to "appear" to OSPF. Some require manual configuration of the neighbor. Some require DR/BDR election, while others do not.

The syntax for this command is..

Router(config-if)# ip ospf network [{broadcast | nonbroadcast | point-to-multipooint | point-to-multipoint nonbroadcast}]

One of these options is bound to work for this question, but is dependant on the specific frame-relay configuration and how you wish it to act.

I hope this helps answer this question. By nature OSPF only works on broadcast networks or true point-to-point networks (not VC's).

~Ryan
 
Yes, there are a couple of ways of getting the neighbors to see each other. Your explanation is correct and using the command
"ip ospf network point-to-point"
does bring the neighbors up.

The other way of bringing the neighbors up is to configure the neighbors explicitly with the neighbor command, like
"neighbor 20.20.20.1 priority 1" for instance.
 
You are absolutely correct and by statically defining the neighbor and not using point-to-point, you are leaving the network type default (on a frame-relay connection, the default is point-to-multipoint) which in most cases is fine. You are also optimizing bandwidth as there are less LSA's sent.

In addition, if you truly do have a point-to-multipoint network (multiple VC's) if you set to point-to-point, OSPF will not act as it should, as this is designed for only one router pair. So in this case, your method is definately preferred.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?