Monday, February 20, 2006

 

BGP prefix advertisement problem. (Question #19)

Consider the following router configured to run BGP. Here is some relevant configuration from the router

interface Ethernet0/0
ip address 10.1.3.1 255.255.255.252
no keepalive
!
router bgp 300
no synchronization
bgp log-neighbor-changes
network 10.1.3.0 mask 255.255.255.0
neighbor 10.1.1.1 remote-as 100
neighbor 10.1.2.1 remote-as 200
no auto-summary


and "show ip route" from the router shows the following

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, Ethernet0/0
C 10.1.2.0 is directly connected, Serial3/0
C 10.1.1.0 is directly connected, Serial2/0


It is seen that this router's BGP neighbors are not learning the route to 10.1.3.0/24 in spite of the fact that this router is advertising that prefix. What is the problem here? How can it be fixed?

Comments:
just type a statement in config mode. i.e

ip route 10.1.3.0 255.255.255.0 null0
 
Yup, that will do the trick.
 
How about changing network (under router bgp 300) 10.1.3.0 mask 255.255.255.0 to
network 10.1.3.0 mask 255.255.255.252 and then adding

aggregate-address 10.1.3.0 255.255.255.0 summary-only


Would this also be a solution?
 
Yes, that will result in the desired behavior also.
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?