Tuesday, February 28, 2006

 

BGP neighbors stuck in ACTIVE. (Question #25)

Consider two routers connected back to back via their serial interfaces. The configurations on the routers are

Router1

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial2
ip address 192.168.16.1 255.255.255.252
no fair-queue
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 20.20.20.20 remote-as 2
neighbor 20.20.20.20 ebgp-multihop 2
neighbor 20.20.20.20 update-source Loopback0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.16.2



Router2

interface Loopback0
ip address 20.20.20.20 255.255.255.255
!
interface Serial2
ip address 192.168.16.2 255.255.255.252
no fair-queue
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
network 172.16.1.0 mask 255.255.255.0
neighbor 10.10.10.10 remote-as 1
neighbor 10.10.10.10 ebgp-multihop 2
neighbor 10.10.10.10 update-source Loopback0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.16.1



These BGP neighbors are stuck in active and never come up. Note that the two routers can ping each other's serial and loopback interfaces with their own serial and loopback interface addresses as the source address. Why are these routers unable to establish BGP neighborship?

Comments:
I think I need a hint. I can't see why it wouldn't work normally.
 
OK. The hint is that the mechanism by which the path to the (wannabe) neighboring BGP router is known matters to BGP w.r.t whether or not it chooses to become a neighbor. I was surprised by this and that is why I put up this question.
 
I still can't figure it out. It works in my configuration. I don't have a serial interface so I tried with a tunnel. I am showing just the static routes for the loopbacks. I have the proper routing so the tunnel comes up and the bgp is established.


Router 1
interface Tunnel0
ip address 172.30.1.2 255.255.255.0
tunnel source 10.10.80.3
tunnel destination 192.168.0.200
!
interface Loopback2
ip address 20.20.20.20 255.255.255.255
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
network 172.30.1.0 mask 255.255.255.0
neighbor 21.21.21.21 remote-as 2
neighbor 21.21.21.21 ebgp-multihop 2
neighbor 21.21.21.21 update-source Loopback2
no auto-summary
!
ip classless
ip route 21.21.21.21 255.255.255.255 172.30.1.1


Router 2

interface Loopback0
ip address 21.21.21.21 255.255.255.255
!
interface Tunnel0
ip address 172.30.1.1 255.255.255.0
tunnel source 192.168.0.200
tunnel destination 10.10.80.3
!
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 20.20.20.20 remote-as 1
neighbor 20.20.20.20 ebgp-multihop 2
neighbor 20.20.20.20 update-source Loopback0
no auto-summary
!
ip classless
ip route 20.20.20.20 255.255.255.255 172.30.1.2
 
Note that your config is different from what I put up in the problem in one critical aspect. You are using a static route to get to the neighbor while my config is using a static default route. Change your static route to be a default route and see if the routers become BGP neighbors or not.
 
Very interesting. I am seeing the same behavior. Did you ever find an explanation?

I just see this in the debug:

*Mar 20 18:38:54.855 EST: BGP: 20.20.20.20 multihop open delayed 14515ms (no route)
 
Yes, I do have the explanation. The questions I put up are all interesting things that I run into that I then reframe as a question.

It is normal BGP behavior to not come up as neighbors if the only way to reach the peer is via a default route. Take a look at

http://www.cisco.com/warp/public/459/24.html#noroutes
 
bgp does not use default routes.
 
I would like to share a list of Cisco exam-related articles and tips, at 100Questions Exam Portal (http://www.100qns.com) . CISCO 640-822 CCENT (100 Questions) is the Cisco Certified Networking Entry Technician exam, and covers the skills required for entry-level network support positions, and is the starting point for many networking careers. CCENT is the first step towards CCNA, and our exam volume prepares you to ace your exam.

CISCO CCNA Exam (100 Questions), or the Cisco Certified Network Associate validates the ability to install, configure, operate and troubleshoot medium-sized routed and switched networks. This includes basic mitigation of security threats, introduction to wireless networking concepts and terminology, and performance-based skills.

The other good thing is that you can test your Cisco knowledge and prepare for the exam via the exam library, which contains free-to-try exam questions. The Cisco reference section could be accessed from the drop-down menu, and because the portal covers several topics, it could be confusing initially due to the enormous amount of data, but if you spend some time navigating the contents you might be well-rewarded!

Another good site (if you need another one) is Exam Fight, at http://www.examfight.com

Hope this helps!

Susan

 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?