Thursday, January 26, 2006

 

Multicast routing over a GRE tunnel. (Question #2)

Consider a network of routers with multicast routing turned on. Somewhere in the network there are a pair of adjacent routers with two equal cost paths between them. You display the config on the routers and see the following -

On Router1


interface Tunnel0
ip address 6.1.1.1 255.255.255.0
ip pim sparse-dense-mode
tunnel source Ethernet0/0
tunnel destination 5.1.1.1
!
interface Ethernet0/1
ip address 2.1.1.1 255.255.255.0
!
interface Ethernet0/2
ip address 3.1.1.1 255.255.255.0



On Router2


interface Tunnel0
ip address 5.1.1.1 255.255.255.0
ip pim sparse-dense-mode
tunnel source Ethernet1/4
tunnel destination 6.1.1.1
!
interface Ethernet1/1
ip address 2.1.1.2 255.255.255.0
!
interface Ethernet1/2
ip address 3.1.1.2 255.255.255.0
!



That is, there is a GRE tunnel between the two routers and multicast is being run over the tunnel rather than directly on the physical interfaces between the two routers.

Why would such a thing be done between directly connected routers both of whom are multicast capable? Is that tunnel superfluous or is it actually being useful in some manner?

Comments:
Running multicast on the tunnel prevents the multicast packets from being broadcasted out the other operational interfaces which reduces the amount of broadcast traffic on the router.

This also keeps multicast traffic from going to any other adjacency on the tunnel source interface.
 
This limits multicast streams to the tunnel interface, which still providing redundancy over multiple physical paths. Without the tunnel, multicast could be sent across multiple physical paths as it sees requests coming in through each.
 
I would like to share a list of Cisco exam-related articles and tips, at 100Questions Exam Portal (http://www.100qns.com) . CISCO 640-822 CCENT (100 Questions) is the Cisco Certified Networking Entry Technician exam, and covers the skills required for entry-level network support positions, and is the starting point for many networking careers. CCENT is the first step towards CCNA, and our exam volume prepares you to ace your exam.

CISCO CCNA Exam (100 Questions), or the Cisco Certified Network Associate validates the ability to install, configure, operate and troubleshoot medium-sized routed and switched networks. This includes basic mitigation of security threats, introduction to wireless networking concepts and terminology, and performance-based skills.

The other good thing is that you can test your Cisco knowledge and prepare for the exam via the exam library, which contains free-to-try exam questions. The Cisco reference section could be accessed from the drop-down menu, and because the portal covers several topics, it could be confusing initially due to the enormous amount of data, but if you spend some time navigating the contents you might be well-rewarded!

Another good site (if you need another one) is Exam Fight, at http://www.examfight.com

Hope this helps!

Susan
 
Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?